Bloomreach Commerce Accelerator 14.3.0 Upgrade Notes - Bloomreach Experience - Open Source CMS

Bloomreach Commerce Accelerator 14.3.0 Upgrade Notes

This Bloomreach Experience Manager feature requires a standard or premium license. Please contact Bloomreach for more information.

Here are the instructions to upgrade to Bloomreach Commerce Accelerator 14.3.0.

For details on the new features and improvements in this release, see the Bloomreach Commerce Accelerator Release Notes.

Note that you should upgrade your project to Bloomreach Commerce Accelerator 14.2.x before upgrading to 14.3.0.

Deprecated APIs and Features

Deprecation of the Commerce Connector SDK

Since v14.3.0, most of the Java-based Commerce Connector SDK has been deprecated since the brX GraphQL Service is preferred. Some APIs for core features such as Commerce Connector metadata or B2B Account abstraction are not deprecated as they are still used even in an integration with the brX GraphQL Service.

Please note that the Java-based Commerce Connector SDK may be dropped in a future major version when all equivalent features for various Commerce Backend Platforms are provided via the brX GraphQL Service.

Deprecation of External Document Picker based Picker UIs

Since v14.3.0, the External Document Picker based Picker Plugins have been deprecated since the Open UI based Pickers are preferred.

Please note that the External Document Picker based Picker Plugins may be dropped in a future major version when all equivalent features for various Commerce Backend Platforms are provided via the Open UI based Pickers.

Upgrading Bloomreach B2C Commerce Accelerator

Upgrade the parent POM dependency in your project:

  <parent>
    <groupId>com.onehippo.cms7</groupId>
    <artifactId>hippo-cms7-enterprise-release</artifactId>
    <version>14.3.0</version>
  </parent>

Update the following properties in the root pom.xml in your project:

    <essentials.version>14.3.0</essentials.version>
    <hippo.addon-universal-pixel-integration.version>14.3.0</hippo.addon-universal-pixel-integration.version>
    <starterstore.version>14.3.0</starterstore.version>

Rebuild and restart your project to verify the upgrade.

Upgrading Bloomreach B2B Commerce Accelerator

Upgrade the parent POM dependency in your project:

  <parent>
    <groupId>com.onehippo.cms7</groupId>
    <artifactId>hippo-cms7-enterprise-release</artifactId>
    <version>14.3.0</version>
  </parent>

Update the following properties in the root pom.xml in your project:

    <essentials.version>14.3.0</essentials.version>
    <hippo.addon-universal-pixel-integration.version>14.3.0</hippo.addon-universal-pixel-integration.version>
    <starterstore.version>14.3.0</starterstore.version>
    <starterstore-b2b.version>14.3.0</starterstore-b2b.version>

Rebuild and restart your project to verify the upgrade.

Did you find this page helpful?
How could this documentation serve you better?
On this page
    Did you find this page helpful?
    How could this documentation serve you better?