Vulnerabilities in Jackson Databind 2.9.8 - BloomReach Experience - Open Source CMS

Vulnerabilities in Jackson Databind 2.9.8 

Issue date: 02-08-2019
Affects versions: 13.1, 13.0, 12.6, 11.2

Issue ID: SECURITY-113

Affected Product Version(s)

This vulnerability affects all versions of both CMS and delivery applications based on Bloomreach Experience Manager prior to 11.2.15, 12.6.5, 13.1.3, and 13.2.1.


Severity 

Critical


Description

A Polymorphic Typing issue was discovered in FasterXML jackson-databind 2.x before 2.9.9. When Default Typing is enabled (either globally or for a specific property) for an externally exposed JSON endpoint, the service has the mysql-connector-java jar (8.0.14 or earlier) in the classpath, and an attacker can host a crafted MySQL server reachable by the victim, an attacker can send a crafted JSON message that allows them to read arbitrary local files on the server. This occurs because of missing com.mysql.cj.jdbc.admin.MiniAdmin validation.

This vulnerability is classified with severity critical. Although default usage of this library within the Hippo CMS product is not vulnerable, project specific usages of the Jackson2 library within a Hippo CMS project may be vulnerable. 

The FasterXML Jackson2 and jackson-databind versions in all supported CMS maintenance versions 11.2.14, 12.6.4, 13.1.2, and 13.2.0 have been updated from 2.9.8 to 2.9.9.

 

Instructions

Every customer is strongly advised to upgrade as soon as possible to the latest maintenance release as indicated above, or higher. This can be done by simply incrementing the version number of the parent POM for the implementation project.