Upgrade Essentials Plug-ins - BloomReach Experience - Open Source CMS

Upgrade Essentials Plug-ins

Template language selection removed

In version 13, support for the template language selection has been removed from Essentials. Your custom Essentials plugin may have made use of this mechanism through the use of the <essentials-simple-install-plugin> directive during (manual) installation. If your Essentials plugins rely on this mechanism, or if they use this directive, you may need to change your plugins in one of the following ways:

  1. Remove the has-no-templates attribute. If your plugin's HTML template uses the <essentials-simple-install-plugin> directive and specifies the has-no-templates attribute, this attribute should be removed, as it is no longer functional.
  2. Update template installation instructions. If your plugins rely on either the "jsp" or the "freemarker" group being activated during installation, that group activation either needs to be implemented in a plugin-specific manner, or the preferred template version needs to be installed unconditionally, by removing the group attribute from the corresponding <instructionSet>, and removing the "opposite" <instructionSet>

 

Did you find this page helpful?
How could this documentation serve you better?
On this page
    Did you find this page helpful?
    How could this documentation serve you better?